# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/stream \([A-Za-z]+\) \{\R\K(?=\})/\(text\)\n/gm;t' <<< "stream (abcd) {
}
stream (efg) {
} "