const regex = new RegExp('stream \\([A-Za-z]+\\) \\{\\R\\K(?=\\})', 'gm')
const str = `stream (abcd) {
}
stream (efg) {
} `;
const subst = `\(text\)\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);