$re = '~stream \([A-Za-z]+\) \{\R\K(?=\})~m';
$str = 'stream (abcd) {
}
stream (efg) {
} ';
$subst = "\(text\)\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;