import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "stream \\([A-Za-z]+\\) \\{\\R\\K(?=\\})";
final String string = "stream (abcd) {\n"
+ "}\n\n"
+ "stream (efg) {\n"
+ "} ";
final String subst = "\\(text\\)\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}