import re
regex = re.compile(r"^(\d*)(-)?(\d*)?$", flags=re.MULTILINE)
test_str = ("3\n"
"1000\n"
"15-20\n"
"20-15\n"
"10-20/2\n"
"1-1000/20\n"
"Above should be legal; this and below should be illegal\n"
" 3 \n"
"03\n"
"2 43\n"
"2x3\n"
"23x\n"
" 15 - 20 \n"
"15--30\n"
"15-03\n"
"15-20-30\n"
"1 5-20\n"
"15-2 0\n"
"15-/20\n"
"15/2-2\n"
"15/10/2")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")