// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d*)(-)?(\d*)?$").unwrap();
let string = "3
1000
15-20
20-15
10-20/2
1-1000/20
Above should be legal; this and below should be illegal
3
03
2 43
2x3
23x
15 - 20
15--30
15-03
15-20-30
1 5-20
15-2 0
15-/20
15/2-2
15/10/2";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}