use strict;
my $str = '2244511556654445454454566436';
my $regex = qr/(?<=\d)(?=(\d{3})+(?!\d))/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";