import Foundation
let pattern = #"(?<=\d)(?=(\d{3})+(?!\d))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2244511556654445454454566436"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)