using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ID_.*?\.pdf";
string input = @"<ul>
<li><a href=""/questions/237104/ID_2556.pdf""><a href=""/questions/237104/ID_2556.pdf"">Click here to
download.</a></li>
<li><a href=""/questions/237104/ID_37.pdf"">Click
here to download.</a></li>
<li><a
href=""/questions/237104/ID_29997.pdf"">Click here to download.</a></li>
<li><a href=""/questions/237104/ID_0554.pdf"">Click here to
download.</a></li>
</ul>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}