# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ID_.*?\.pdf"
test_str = ("<ul>\n"
"<li><a href=\"/questions/237104/ID_2556.pdf\"><a href=\"/questions/237104/ID_2556.pdf\">Click here to\n"
"download.</a></li>\n"
"<li><a href=\"/questions/237104/ID_37.pdf\">Click\n"
"here to download.</a></li>\n"
"<li><a\n"
"href=\"/questions/237104/ID_29997.pdf\">Click here to download.</a></li>\n"
"<li><a href=\"/questions/237104/ID_0554.pdf\">Click here to\n"
"download.</a></li>\n"
"</ul>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.