// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ID_.*?\.pdf").unwrap();
let string = "<ul>
<li><a href=\"/questions/237104/ID_2556.pdf\"><a href=\"/questions/237104/ID_2556.pdf\">Click here to
download.</a></li>
<li><a href=\"/questions/237104/ID_37.pdf\">Click
here to download.</a></li>
<li><a
href=\"/questions/237104/ID_29997.pdf\">Click here to download.</a></li>
<li><a href=\"/questions/237104/ID_0554.pdf\">Click here to
download.</a></li>
</ul>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}