import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ID_.*?\\.pdf";
final String string = "<ul>\n"
+ "<li><a href=\"/questions/237104/ID_2556.pdf\"><a href=\"/questions/237104/ID_2556.pdf\">Click here to\n"
+ "download.</a></li>\n"
+ "<li><a href=\"/questions/237104/ID_37.pdf\">Click\n"
+ "here to download.</a></li>\n"
+ "<li><a\n"
+ "href=\"/questions/237104/ID_29997.pdf\">Click here to download.</a></li>\n"
+ "<li><a href=\"/questions/237104/ID_0554.pdf\">Click here to\n"
+ "download.</a></li>\n"
+ "</ul>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}