#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\s\S]*Subject\s*:.*([\s\S]+)"
Local $sString = "From: Jeremy<br />" & @CRLF & _
" Sent: 22 Apr 2016 12:08:03</br />" & @CRLF & _
" To: Mark<br />" & @CRLF & _
" Subject: Another test email<br /><br />" & @CRLF & _
"" & @CRLF & _
" Hi Mark, " & @CRLF & _
"<br />" & @CRLF & _
"Subject : ghfghfh " & @CRLF & _
"I'm sending this email as a way to test the email! " & @CRLF & _
"<br />" & @CRLF & _
"Cheers, " & @CRLF & _
"<br />" & @CRLF & _
"Jeremy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")