$re = '/[\s\S]*Subject\s*:.*([\s\S]+)/m';
$str = 'From: Jeremy<br />
Sent: 22 Apr 2016 12:08:03</br />
To: Mark<br />
Subject: Another test email<br /><br />
Hi Mark,
<br />
Subject : ghfghfh
I\'m sending this email as a way to test the email!
<br />
Cheers,
<br />
Jeremy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);