const regex = /[\s\S]*Subject\s*:.*([\s\S]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\s\\S]*Subject\\s*:.*([\\s\\S]+)', 'gm')
const str = `From: Jeremy<br />
Sent: 22 Apr 2016 12:08:03</br />
To: Mark<br />
Subject: Another test email<br /><br />
Hi Mark,
<br />
Subject : ghfghfh
I'm sending this email as a way to test the email!
<br />
Cheers,
<br />
Jeremy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}