#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^.*(ACME|Broadway).*$"
Local $sString = "ACME Corp 123" & @CRLF & _
"Corp 742 ACME" & @CRLF & _
"Random Text" & @CRLF & _
"Broadway 1785 FB"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)