// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*(ACME|Broadway).*$").unwrap();
let string = "ACME Corp 123
Corp 742 ACME
Random Text
Broadway 1785 FB";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}