using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(ACME|Broadway).*$";
string substitution = @"$1";
string input = @"ACME Corp 123
Corp 742 ACME
Random Text
Broadway 1785 FB";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}