re = /^.*(ACME|Broadway).*$/m
str = 'ACME Corp 123
Corp 742 ACME
Random Text
Broadway 1785 FB'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result