# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:(a|b|z)(?:;|$)([^;\r\n]*)(?:;|$)([^;\r\n]*)(?:;.*)?$|.*$\R?)/$3/gm;t' <<< "a;; z
z;d;hh
d;23
;;io;
b;b;12
a;b;bb;;;34"