$re = '/^(?:(a|b|z)(?:;|$)([^;\r\n]*)(?:;|$)([^;\r\n]*)(?:;.*)?$|.*$\R?)/m';
$str = 'a;; z
z;d;hh
d;23
;;io;
b;b;12
a;b;bb;;;34';
$subst = "$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;