const regex = /^(?:(a|b|z)(?:;|$)([^;\r\n]*)(?:;|$)([^;\r\n]*)(?:;.*)?$|.*$\R?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(a|b|z)(?:;|$)([^;\\r\\n]*)(?:;|$)([^;\\r\\n]*)(?:;.*)?$|.*$\\R?)', 'gm')
const str = `a;; z
z;d;hh
d;23
;;io;
b;b;12
a;b;bb;;;34`;
const subst = `$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);