#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(a|b|z)(?:;|$)([^;\r\n]*)(?:;|$)([^;\r\n]*)(?:;.*)?$|.*$\R?)"
Local $sString = "a;; z" & @CRLF & _
"z;d;hh " & @CRLF & _
"d;23" & @CRLF & _
";;io;" & @CRLF & _
"b;b;12" & @CRLF & _
"" & @CRLF & _
"a;b;bb;;;34"
Local $sSubst = "$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)