using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\/\&?]{4,})(?:[\/\&\?])(.*?(?:[\/\&\?])\1){3,}";
string input = @"http://examplepage.com/fish/cssms/chrome/cssms/chrome/cssms/pages/browse/cssms/pages/misc/
http://examplepage.com/fish/cssms&chrome&cssms&chrome&cssms/pages/browse/cssms/pages/misc/
http://examplepage.com/fish/cssms?chrome?cssms?chrome?cssms?pages/browse/cssms/pages/misc/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}