import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\\/\\&?]{4,})(?:[\\/\\&\\?])(.*?(?:[\\/\\&\\?])\\1){3,}";
final String string = "http://examplepage.com/fish/cssms/chrome/cssms/chrome/cssms/pages/browse/cssms/pages/misc/\n"
+ "http://examplepage.com/fish/cssms&chrome&cssms&chrome&cssms/pages/browse/cssms/pages/misc/\n"
+ "http://examplepage.com/fish/cssms?chrome?cssms?chrome?cssms?pages/browse/cssms/pages/misc/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}