$re = '/([^\/\&?]{4,})(?:[\/\&\?])(.*?(?:[\/\&\?])\1){3,}/';
$str = 'http://examplepage.com/fish/cssms/chrome/cssms/chrome/cssms/pages/browse/cssms/pages/misc/
http://examplepage.com/fish/cssms&chrome&cssms&chrome&cssms/pages/browse/cssms/pages/misc/
http://examplepage.com/fish/cssms?chrome?cssms?chrome?cssms?pages/browse/cssms/pages/misc/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);