re = /([^\/\&?]{4,})(?:[\/\&\?])(.*?(?:[\/\&\?])\1){3,}/
str = 'http://examplepage.com/fish/cssms/chrome/cssms/chrome/cssms/pages/browse/cssms/pages/misc/
http://examplepage.com/fish/cssms&chrome&cssms&chrome&cssms/pages/browse/cssms/pages/misc/
http://examplepage.com/fish/cssms?chrome?cssms?chrome?cssms?pages/browse/cssms/pages/misc/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end