#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\w]+)(?:(?:\[([\w]+)\])+)?"
Local $sString = "name" & @CRLF & _
" " & @CRLF & _
"name[one]" & @CRLF & _
" " & @CRLF & _
"name[one][two]" & @CRLF & _
"" & @CRLF & _
"name[one][two][three]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")