re = /([\w]+)(?:(?:\[([\w]+)\])+)?/
str = 'name
name[one]
name[one][two]
name[one][two][three]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end