package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([\w]+)(?:(?:\[([\w]+)\])+)?`)
var str = `name
name[one]
name[one][two]
name[one][two][three]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}