$re = '/([\w]+)(?:(?:\[([\w]+)\])+)?/';
$str = 'name
name[one]
name[one][two]
name[one][two][three]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);