using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:\.\d{1,4})?$";
string input = @"4.1
421.11
467.111
438904.1111
0.1
not
1234.
.125
1234.a
489.a
435.aaa
412.1aaaa
1567.11a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}