import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:\\.\\d{1,4})?$";
final String string = "4.1\n\n"
+ "421.11\n\n"
+ "467.111\n\n"
+ "438904.1111\n\n"
+ "0.1\n\n"
+ "not\n\n"
+ "1234.\n\n"
+ ".125\n\n"
+ "1234.a\n\n"
+ "489.a\n\n"
+ "435.aaa\n\n"
+ "412.1aaaa\n\n"
+ "1567.11a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}