$re = '/^\d+(?:\.\d{1,4})?$/m';
$str = '4.1
421.11
467.111
438904.1111
0.1
not
1234.
.125
1234.a
489.a
435.aaa
412.1aaaa
1567.11a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);