import re
regex = re.compile(r"^\d+(?:\.\d{1,4})?$", flags=re.MULTILINE)
test_str = ("4.1\n\n"
"421.11\n\n"
"467.111\n\n"
"438904.1111\n\n"
"0.1\n\n"
"not\n\n"
"1234.\n\n"
".125\n\n"
"1234.a\n\n"
"489.a\n\n"
"435.aaa\n\n"
"412.1aaaa\n\n"
"1567.11a")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")