#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-zA-Z0-9]+)\.([a-zA-Z0-9]{1,3})?"
Local $sString = "hotmail." & @CRLF & _
"living." & @CRLF & _
"item." & @CRLF & _
"2." & @CRLF & _
"4S." & @CRLF & _
"hotmail.com" & @CRLF & _
"living.org" & @CRLF & _
"item.co" & @CRLF & _
"2.321" & @CRLF & _
"4S.123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")