$re = '/([a-zA-Z0-9]+)\.([a-zA-Z0-9]{1,3})?/m';
$str = 'hotmail.
living.
item.
2.
4S.
hotmail.com
living.org
item.co
2.321
4S.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);