package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-zA-Z0-9]+)\.([a-zA-Z0-9]{1,3})?`)
var str = `hotmail.
living.
item.
2.
4S.
hotmail.com
living.org
item.co
2.321
4S.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}