using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^(?:.*/)?(?:logs|testing_do_not_delete)(?:/.*)?$";
string input = @"logs
testing_do_not_delete
/logs/
/testing_do_not_delete/
text here/logs
text here/testing_do_not_delete
text here/logs/
text here/testing_do_not_delete/
text here/logs/ more text
text here/testing_do_not_delete/ more 123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}