re = /(?i)^(?:.*\/)?(?:logs|testing_do_not_delete)(?:\/.*)?$/m
str = 'logs
testing_do_not_delete
/logs/
/testing_do_not_delete/
text here/logs
text here/testing_do_not_delete
text here/logs/
text here/testing_do_not_delete/
text here/logs/ more text
text here/testing_do_not_delete/ more 123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end