$re = '~(?i)^(?:.*/)?(?:logs|testing_do_not_delete)(?:/.*)?$~m';
$str = 'logs
testing_do_not_delete
/logs/
/testing_do_not_delete/
text here/logs
text here/testing_do_not_delete
text here/logs/
text here/testing_do_not_delete/
text here/logs/ more text
text here/testing_do_not_delete/ more 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);