import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?:.*/)?(?:logs|testing_do_not_delete)(?:/.*)?$";
final String string = "logs\n"
+ "testing_do_not_delete\n"
+ "/logs/\n"
+ "/testing_do_not_delete/\n\n"
+ "text here/logs\n"
+ "text here/testing_do_not_delete\n\n"
+ "text here/logs/\n"
+ "text here/testing_do_not_delete/\n\n"
+ "text here/logs/ more text\n"
+ "text here/testing_do_not_delete/ more 123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}