using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\/?[A-Z]+-([^\/\n]+))";
string input = @"ABCD-ABCD
ABCD-ABCD/EFGH-1
ABCD-ABCD/EFGH-1/IJKL-9
ABCD-ABCD/EFGH-1/IJKL-9/MNOP-432
ABCD-ABCD/EFGH-1/IJKL-9/MNOP-432/QRST-C20-Blatt-4";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}