import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\/?[A-Z]+-([^\\/\\n]+))";
final String string = "ABCD-ABCD\n"
+ "ABCD-ABCD/EFGH-1\n"
+ "ABCD-ABCD/EFGH-1/IJKL-9\n"
+ "ABCD-ABCD/EFGH-1/IJKL-9/MNOP-432\n"
+ "ABCD-ABCD/EFGH-1/IJKL-9/MNOP-432/QRST-C20-Blatt-4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}