// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\/?[A-Z]+-([^\/\n]+))").unwrap();
let string = "ABCD-ABCD
ABCD-ABCD/EFGH-1
ABCD-ABCD/EFGH-1/IJKL-9
ABCD-ABCD/EFGH-1/IJKL-9/MNOP-432
ABCD-ABCD/EFGH-1/IJKL-9/MNOP-432/QRST-C20-Blatt-4";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}