$re = '/(?:\/?[A-Z]+-([^\/\n]+))/';
$str = 'ABCD-ABCD
ABCD-ABCD/EFGH-1
ABCD-ABCD/EFGH-1/IJKL-9
ABCD-ABCD/EFGH-1/IJKL-9/MNOP-432
ABCD-ABCD/EFGH-1/IJKL-9/MNOP-432/QRST-C20-Blatt-4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);