import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\w+\\b *\\.(?!(rM|rD|srM|ssiM))";
final String string = "ooF .rM\n"
+ "raB .rD olleH\n"
+ "zzuB .ssiM\n"
+ "zzaB .srM gnitseT\n\n"
+ "hctaM .dluohs sihT";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}