$re = '/\b\w+\b *\.(?!(rM|rD|srM|ssiM))/i';
$str = 'ooF .rM
raB .rD olleH
zzuB .ssiM
zzaB .srM gnitseT
hctaM .dluohs sihT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);