const regex = /\b\w+\b *\.(?!(rM|rD|srM|ssiM))/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\w+\\b *\\.(?!(rM|rD|srM|ssiM))', 'gi')
const str = `ooF .rM
raB .rD olleH
zzuB .ssiM
zzaB .srM gnitseT
hctaM .dluohs sihT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}