re = /\b\w+\b *\.(?!(rM|rD|srM|ssiM))/i
str = 'ooF .rM
raB .rD olleH
zzuB .ssiM
zzaB .srM gnitseT
hctaM .dluohs sihT'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end